DomainMOD v4.20 Released — Compatibility Updates

Unfortunately this isn’t a fun or sexy release with a bunch of new features, but it’s a much needed one. Since there hasn’t been a new release of DomainMOD for a little while now, some of the underlying software version requirements got a bit out-of-date. Some of the newest versions of MariaDB and MySQL had compatibility issues, and would throw errors in certain situations.

I’ve spent a bunch of time in v4.20 updating DomainMOD to work with all of the currently-supported versions of PHP*, MariaDB, and MySQL, and the newest DomainMOD version requirements are as follows:

PHP: 8.1-8.2.9
MariaDB: 10.4-11.1.2 or MySQL 5.7-8.1.0

If you’re planning to upgrade DomainMOD, you should make sure that your server meets the above requirements. If it’s still running PHP 8.0, you should wait until you can upgrade your server to PHP 8.1 or higher before you upgrade to DomainMOD v4.20.

* – Although PHP 8.0 is technicaly being supported for a couple more months, some of DomainMOD’s dependencies now require PHP 8.1, so we’ve had to retire PHP 8.0 support a little bit early.

DomainMOD